Bug/Site Problem: New glitches with PNG preview

Discussion in 'Main Site & Forum Support' started by Alisenokmouse, Mar 4, 2017.

Tags:
  1. Alisenokmouse

    Alisenokmouse New Member

    Probably after fixing GIF preview glitch, or maybe after maintenance today (not sure), here is a new glitch, but with PNG drawings (likely because of its transparency). And it works a bit weird D:

    For example:

    Thumbnail is OK, fullsize is OK, but 400px preview is like that:
    [​IMG]

    though, I just uploaded another my drawing and:
    fullsize is OK, 400px preview is OK, but thumbnail (this strip at the top of picture):
    [​IMG]

    ;-; any ideas?
     
  2. jayhusky

    jayhusky Well-Known Member

    Have you tried saving them as PNG (non-interlaced) and in PNG-24 format?
     
  3. Alisenokmouse

    Alisenokmouse New Member

    well, I always save my PNG as non-interlaced, I guess? o:

    (I hope FA will not ban me for all these tests XD)
    I tried these ways:

    PNG-24 non-interlaced (thumbnail & 400px preview), I uploaded it twice and both times got different results:
    [​IMG] [​IMG]

    [​IMG] [​IMG]

    PNG-24 interlaced, 400px preview is OK, but thumbnail gives various glitches each time:
    upd.: oh, no, PNG-24 interlaced - 400px preview is not ok too, I see very small black line at the top of image
    [​IMG] [​IMG]
    [​IMG]
     
  4. jayhusky

    jayhusky Well-Known Member

    They shouldn't ban you for this.
    I can't think of why it would be doing this, right now, but you could get around the issue by uploading the file as you would normally and then updating the thumbnail with the same file.
    It shouldn't need to work on the image, so the weird pixel effect should disappear.
     
  5. Alisenokmouse

    Alisenokmouse New Member

    When I update anything (submission file or thumbnail) - both(!) versions are re-modified. As I understand, there is a very small chance that the glitch will be unnoticeable, but just now I updated the drawing about 10 times and it is still with the weird lines at the top of the image. I had an option, when the 400px preview was completely(?) normal, but the thumbnail was composed entirely of glitches... I think, here is ~2-5% chance to get normal picture XD

    By the way, are you sure that the thumbnail update system works right?
    I mean, when I changed submission file, I off the check from "Rebuild the thumbnail from this file", but the thumbnail still has changed! And it was also with glitches. New variations of glitches...


    Maybe this information will be useful - I have never encountered this problem before. And more than obvious, I suppose, that this may be due to the recent updates (GIF glitch fixes).
    3 days ago I uploaded this picture and everything was perfect, but now I upload the same picture and got this:
     
  6. jayhusky

    jayhusky Well-Known Member

    It is entirely possible that the update did change a setting which proved detrimental to the PNG files.

    It is also possible that the site is attempting to rebuild it's thumbs db, and that is why the thumbnail is being remade even when you don't want it to.
     
  7. jayhusky

    jayhusky Well-Known Member

    Alisenokmouse likes this.
  8. yak

    yak Administrator Staff Member

    @jayhusky thanks, I was about to post a reply here :)
     
    jayhusky likes this.
  9. jayhusky

    jayhusky Well-Known Member

    No problem. :)
     
  10. Alisenokmouse

    Alisenokmouse New Member

Share This Page