• Fur Affinity Forums are governed by Fur Affinity's Rules and Policies. Links and additional information can be accessed in the Site Information Forum.

Help With Panasonic VX870; Error While Recording


So I got a Panasonic HC-VX870 camcorder. It’s great. When a recording hits 10 minutes in length, it ends one recording and starts a new file. This isn’t unusual. I put a new memory card in it. 256 GB, if I recall. I think it’s the correct type and everything. But now I have a problem. If the recording gets too long, the camera errors out and the recording becomes corrupted. Something about control data error.

The manual doesn’t say a whole lot about the error. In fact, it says almost nothing. I found one single promising result online while searching for a solution. Someone else was having basically the same issue. They would record for a little bit and then the camera would error out. They were told to format the card through the camera itself as opposed to using a computer. It almost worked for the user. They were able to record for longer, but was still hit with the error (and corrupted files). The next solution was that the card may not have had a high enough data write speeds. The user swapped cards and that’s where the thread ends; they never came back to say if that worked or not.

Now, I’m not saying that the write speeds aren’t what’s up with mine, but here are some things to consider. My recording usually make it to the 7-9 minutes mark in record length. The sizes of the corrupted files all fall a couple hundred megs shy of hitting 4 GB (about 3.7 - 3.8 GB). This tells me that it’s an issue with the card’s file system. Windows is saying it’s in the exFAT format, but I’m wondering if it’s actually FAT or FAT32 being reported as exFAT since Windows no longer supports the original FATs.

So here’s a summary:
The camera stops recording and errors out when files start to hit 4 GB in size, indicating it’s a file system issue. But cards previously used and formatted in the camera would work properly, indicating it might be a write speed issue instead. But if it’s a write speed issue, why is it that the only consistency between the corrupted files is their sizes? Put it in a well-lit area with lots of motion, it’ll error out in just a few minutes. Put it in a dark area with little to no movement and it’ll record for longer…but will still error out at just under 4 GB in size.

What do you all think?

I can’t find anything about this, but can any of you find out (or happen to already know) what supported file systems the camera supports? The manual says nothing, nor does any specs list I find online.
Last edited: