• Fur Affinity Forums are governed by Fur Affinity's Rules and Policies. Links and additional information can be accessed in the Site Information Forum.

Streamlabs OBS, streaming help?

TheCoyoteQueen

DarkBlood
I feel like I have posted this same exact post a year ago XD I am having trouble with streamlabs obs after I had to uninstall and redownload. I can't figure out the correct numbers to stream without severe lag in my paint tool sai or severe lag on the stream. I have tried googling the answer but I guess I am not the best at researching that sort of thing. Before I uninstalled I had it perfect and I guess I should have saved a screenshot of it.
 
Few things of interest.
Tell us what CPU you have.
Tell us what kind of GPU you have.
And lastly tell us what kind of internet connection you have(mostly upload)

The first two play a big role in what kind of settings to go for straight away instead of going in blind, the last one is mostly of extra interest as if your upload isn't enough the stream might not be as enjoyable for those watching. All three need to be up to snuff for the specific required settings you try to stream at.
 

TheCoyoteQueen

DarkBlood
I am so sorry but the only thing I know how to do is pull up performance under task manager. It shows cpu and gpu but I am no sure which numbers to give... I took screenshots though if that helps? I hope it does.
Thank you for trying to help me out!
sta.sh: Cpu
 
Alright, from the information you give on the processor in the screens there however is that an intel celeron of any kind is not really good enough for most streaming tasks when using the regular x264 encoding that makes use of the processor directly.

There are different ways you can set a stream to encode so it takes some load off the processor cores themselves to encode the stream and from what I see here: Intel® Celeron® Processor N3350 (2M Cache, up to 2.4 GHz) Product Specifications
is that even the celeron you are using it should support quicksync, and in your case it's your best alternative.

However, quicksync is not supported in Streamlabs yet as far as I know, so I'd highly recommend you to get regular OBS studio instead and see if the alternative for quicksync is there as I believe it should at least be able to stream roughly at 1000+ bitrate and 720p. Never really used it myself as my own systems never had it though so don't take my word for it, but it's your best option. Someone is free to tell me wrong that might have more experience streaming on this kind of hardware.

There's good tutorials out there on youtube on how to set up streaming using quicksync and OBS studio I believe.

If you'd still insist on using streamlabs, all you can do is set everything to lowest and go from there.
-CBR and no bitrate probably no higher than 500(Moving media will not look good as this bitrate is very low but a canvas and art should work)
-Ultrafast or at least superfast preset for CPU usage
In video tab:
-Base canvas should be no higher than 720p
-Fps value no higher than 25
Something of that sorts is where you should start, because in all honesty I am not even sure how well a celeron would handle those settings.

With all this said you also need to have stable connection with plenty enough upload for the stream of data you send out, otherwise it might lag for others of course.
 

TheCoyoteQueen

DarkBlood
I will try out regular OBS, I think that is what I had before. Well for some reason I had both obs and streamlabs but I always chose streamlabs. Thanks for all of the help, I will try it out and let you know how it went!
I spend my entire day drawing on this thing and I can never figure out whats going on! Had it almost two years
 
Top