• Fur Affinity Forums are governed by Fur Affinity's Rules and Policies. Links and additional information can be accessed in the Site Information Forum.

Tinychat doesn't like ubuntu


Resistance is futile! If 0 ohm
I can't seem to get it to work, need help. I have my mic on and it's unmuted.
I tried changing my flash player settings but for some reason they reset everytime I close firefox.
Last edited:


Resistance is futile! If 0 ohm
Can you run us through what's going on?
I'm on tinychat, I click start broadcasting, select your camera, don't use a camera, linux microphone.
It says say something in the microphone, I say something but it won't register my voice.
I click through and it won't register me speaking.
I found this
but I don't understand progammer speak.

south syde dobe

4th Elite General
I had unbuntu on my laptop but since I wiped the drive it's gone now :\


The hell am I reading, here?
Tinychat sucks anyways.


'Net Help Desk
That UbuntuForums thread said that Flash freezes because it can't resize the webcam video stream. It also says that it's working properly in Flash Player 10.1, which was beta at the time of the post but is now final.

http://www.adobe.com/software/flash/about/ will tell you what version of Flash you have installed. Let us know whether it's 10.1.xx.xx or not.


My avatar creeps me out.
Did you try what this guy wrote?

Too_Lazy_To_Fix_it_Right said:
In Ubuntu Hardy you were used to be asked to grant permission to the website you were visiting to take control on your webcam (through some flash popup with the settings). It seems that recent versions of Adobe flash player (the updated ones for Intrepid and Jaunty since June 2009, at least, and probably before also) have a bug which doesn't ask the user to grant access to a site when visiting it. Like ustream.tv for streaming using your webcam, as example.

The workaround is to grant access to that website by default without attempting to ask you each time.
* You need to go to: http://www.macromedia.com/support/do...manager06.html
* Choose the "Website privacy settings" * Select the site from the list of visited websites. * click on the option "always allow" above the list.
You should see that the icon on the left of that site in the list changes from yellowish to green colour. That's it.
Try again visiting that website, ustream.tv in this example, and your webcam should be streaming again as it used to do back with Hardy.


Why are you using Ubuntu if you don't understand "programmer speak"?
Barely anything in Linux works flawlessly out of the box. If you want things to just work without having to mess around with a command line, use Windows or OSX.


My avatar creeps me out.
Last edited:


Resistance is futile! If 0 ohm

I'm not exactly the Linux authority here, but I would recommend following the directions laid out on the bottom of this page. Anybody care to second this reckless-ish suggestion?

It seems to be the same issue; flash offers "Linux Microphone" instead of real mic options, though mic works elsewhere.

Congrats on seeing the light!
I have the same problem, I tried it but didn't work.


Resistance is futile! If 0 ohm
^I'm installing it right now.
so, Mac it is then?
I'm staying with linux.

Shit piss, fuck shit, I have it installed and it still didn't work. I know it's not my microphone, because it works fine otherwise.
Last edited:


My avatar creeps me out.
Shit piss, fuck shit, I have it installed and it still didn't work. I know it's not my microphone, because it works fine otherwise.

Maybe try a different browser? I hear Chrome works pretty well in Linux.


My avatar creeps me out.
This is the computer glitch from hell.

Are you using the default Ubuntu sound architecture? (ALSA?)

According to the flash player release notes, that's the only arch it supports.

Also, try this link

And check version number and issues there.

It looks like there are alot of people having this problem and no solutions, since Adobe has little reason to support Linux. The only solution I saw would involve making audio output inaccessible to flash player, which would be counter-productive for tinychat.

This is just another prime example of flash failing to behave like an internet standard should. All you can do is file a bug report or try to patch fp yourself.


Resistance is futile! If 0 ohm
Looking through it right now, oh hey did you know linux has a voip program you can install?
Also I do have alsa installed already.
Last edited:


I like to nuke ^^
Hmm ...
Did you try starting the browser of your choice from a terminal and then hop into a tinychat room? If not, do so, maybe you're lucky and get an error message in the terminal (for example, permission denied and stuff, looks like tinychat is a real bitch that has so many flaws that it's easier to run the browser as root).